Scomposizione in numeri primi usando le funzioni di excel

Appunto inviato da ansane
/5

Come creare velocemente un semplice programma per la scomposizione in numeri primi (1 pagine formato pdf)

SCOMPOSIZIONE IN NUMERI PRIMI

Scomposizione in numeri primi.

Apriamo Excel. Dopo aver scritto il titolo, posizioniamoci in A2 e digitiamo “N=”, nella cella B2 scriviamo il numero da scomporre.
Andiamo in A4 e scriviamo: “=A2”, così Excel riporterà il numero da scomporre, nella cella B4 dobbiamo riportare “2”, il primo numero primo, e in C4:
“=RESTO(A2;B4)”
questo passaggio, farà riportare al programma il resto della divisione tra il numero ed il numero primo (2). In E4 riportiamo:
“=SE(C4=0;A2/B4;“ ”)”
vale a dire, se il restio della divisione è pari a 0, esegui la divisione, se no, lascia uno spazio vuoto.
In A5:
“=SE(C4=0;A4/B4;A4)”
ovvero, se il resto della divisione sopraccitata è 0, esegui la divisione, se no riporta il numero da scomporre.

Numeri naturali: definizione

SCOMPORRE IN NUMERI PRIMI

In B5:
“=SE(C4=0;B4;B4+1)”
in altre parole, se il resto della nota divisione è 0, riporta il numero primo (2), se no, aggiungi “1” al numero primo (2+1).

Questo passaggio permetterà di scomporre qualunque cifra.
Copiamo e incolliamo da C4 a C5 e da E4 a E5.
Ora non resta che trascinare da A5:E6 fino alla riga che ci interessa, ovvero, quella con il risultato.
La scomposizione è terminata quando nella colonna “A” è possibile leggere il valore “1” (vedi esempio: A23).
I valori della scomposizione sono riportati nella colonna “E” e sono ordinati verticalmente “a cascata”.
Ricordate che questo programma non svolge la scomposizione di numeri con più di 9 cifre.